0

bst365体育投注网址大全i have tired adding this ruby repo for installing 2.4 version of ruby, the error message is shown bellow

sudo apt-add-repository ppa:brightbox/ruby-ng

but i got this error i have tried all this links

python add-apt-repository: ImportError: No module named 'apt_pkg'

How to fix 'ModuleNotFoundError: No module named 'apt_pkg'?

Traceback (most recent call last):
  File "/usr/bin/apt-add-repository", line 11, in <module>
    from softwareproperties.SoftwareProperties import SoftwareProperties, shortcut_handler
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 28, in <module>
    import apt_pkg
ModuleNotFoundError: No module named 'apt_pkg'
0
0

bst365体育投注网址大全Try these methods and find if it works

apt-get remove --purge python-apt

and then

apt-get install python-apt
| improve this answer | |
  • its not working same apt_pkg error – Gautham Arcot Jul 1 at 6:08
  • Are you executing this command in the Dockerfile ? – Jananath Banuka Jul 1 at 6:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policybst365体育投注网址大全

Not the answer you're looking for? Browse other questions tagged or ask your own question.